Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2011-0992

Overview

Vulnerability Score 5.8 5.8
CVE Id CVE-2011-0992
Last Modified 14 Apr 2011 12:00:00
Published 13 Apr 2011 05:55:00
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact NONE NONE
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2011-0992

Summary

Use-after-free vulnerability in Mono, when Moonlight 2.x before 2.4.1 or 3.x before 3.99.3 is used, allows remote attackers to cause a denial of service (plugin crash) or obtain sensitive information via vectors related to member data in a resurrected MonoThread instance.

Vulnerable Systems

Application

  • Mono

  • Novell Moonlight 2.0

  • Novell Moonlight 2.3.0

  • Novell Moonlight 2.31

  • Novell Moonlight 2.4

  • Novell Moonlight 3.0

  • Novell Moonlight 3.99


References

CONFIRM - https://github.com/mono/mono/commit/722f9890f09aadfc37ae479e7d946d5fc5ef7b91

CONFIRM - https://bugzilla.redhat.com/show_bug.cgi?id=694933

CONFIRM - https://bugzilla.novell.com/show_bug.cgi?id=667077

MLIST - [oss-security] 20110406 Moonlight release 2.4.1 with security fixes

CONFIRM - https://bugzilla.novell.com/show_bug.cgi?id=678515

XF - momo-monothread-info-disclosure(66627)

VUPEN - ADV-2011-0904

BID - 47208

CONFIRM - http://www.mono-project.com/Vulnerabilities

SECUNIA - 44076

SECUNIA - 44002

MLIST - [opensuse-updates] 20110408 openSUSE-SU-2011:0313-1 (critical): moonlight security update


Last Updated: 27 May 2016 10:56:07