Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2011-1148

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2011-1148
Last Modified 03 Feb 2012 10:57:53
Published 18 Mar 2011 11:55:01
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2011-1148

Summary

Use-after-free vulnerability in the substr_replace function in PHP 5.3.6 and earlier allows context-dependent attackers to cause a denial of service (memory corruption) or possibly have unspecified other impact by using the same variable for multiple arguments.

Vulnerable Systems

Application

  • Php 1.0

  • Php 2.0

  • Php 2.0b10

  • Php 3.0

  • Php 3.0.1

  • Php 3.0.10

  • Php 3.0.11

  • Php 3.0.12

  • Php 3.0.13

  • Php 3.0.14

  • Php 3.0.15

  • Php 3.0.16

  • Php 3.0.17

  • Php 3.0.18

  • Php 3.0.2

  • Php 3.0.3

  • Php 3.0.4

  • Php 3.0.5

  • Php 3.0.6

  • Php 3.0.7

  • Php 3.0.8

  • Php 3.0.9

  • Php 4.0

  • Php 4.0.0

  • Php 4.0.1

  • Php 4.0.2

  • Php 4.0.3

  • Php 4.0.4

  • Php 4.0.5

  • Php 4.0.6

  • Php 4.0.7

  • Php 4.1.0

  • Php 4.1.1

  • Php 4.1.2

  • Php 4.1.3

  • Php 4.2

  • Php 4.2.0

  • Php 4.2.1

  • Php 4.2.2

  • Php 4.2.3

  • Php 4.2.4

  • Php 4.3

  • Php 4.3.0

  • Php 4.3.1

  • Php 4.3.10

  • Php 4.3.11

  • Php 4.3.2

  • Php 4.3.3

  • Php 4.3.4

  • Php 4.3.5

  • Php 4.3.6

  • Php 4.3.7

  • Php 4.3.8

  • Php 4.3.9

  • Php 4.4.0

  • Php 4.4.1

  • Php 4.4.2

  • Php 4.4.3

  • Php 4.4.4

  • Php 4.4.5

  • Php 4.4.6

  • Php 4.4.7

  • Php 4.4.8

  • Php 4.4.9

  • Php 5.3.0

  • Php 5.3.1

  • Php 5.3.2

  • Php 5.3.3

  • Php 5.3.4

  • Php 5.3.5

  • Php 5.3.6


References

XF - php-substrreplace-code-exec(66080)

BID - 49241

BID - 46843

CONFIRM - http://www.php.net/ChangeLog-5.php#5.3.7

CONFIRM - http://www.php.net/archive/2011.php#id2011-08-18-1

MLIST - [oss-security] 20110313 Re: CVE request: PHP substr_replace() use-after-free

MLIST - [oss-security] 20110313 CVE request: PHP substr_replace() use-after-free

CONFIRM - http://bugs.php.net/bug.php?id=54238

REDHAT - RHSA-2011:1423

MANDRIVA - MDVSA-2011:165

CONFIRM - http://support.apple.com/kb/HT5130

APPLE - APPLE-SA-2012-02-01-1

Related Patches

Apple 2012-02-01 Mac OS X Server 10.7.3 Update

Apple 2012-02-01 Mac OS X 10.7.3 Update

Apple 2012-02-01 Mac OS X Server 10.7.3 Combo Update

Apple 2012-02-01 Mac OS X 10.7.3 Combo Update

Apple 2012-02-01 Security Update 2012-001 v1.1 Server (Snow Leopard)

Apple 2012-02-01 Security Update 2012-001 v1.1 (Snow Leopard)

Red Hat 2011:1423-01 RHSA Moderate: php53 and php security update for RHEL 5 x86

Red Hat 2012:0033-01 RHSA Moderate: php security update for RHEL 5 x86

Red Hat 2012:0033-01 RHSA Moderate: php security update for RHEL 5 x86_64


Last Updated: 27 May 2016 10:58:04