Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2011-1412

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2011-1412
Last Modified 19 Mar 2012 12:00:00
Published 03 Aug 2011 10:45:32
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2011-1412

Summary

sys/sys_unix.c in the ioQuake3 engine on Unix and Linux, as used in World of Padman 1.5.x before 1.5.1.1 and OpenArena 0.8.x-15 and 0.8.x-16, allows remote game servers to execute arbitrary commands via shell metacharacters in a long fs_game variable.

Vulnerable Systems

Application

  • Ioquake3 Engine

  • Openarena 0.8.x-15

  • Openarena 0.8.x-16

  • Worldofpadman World Of Padman 1.5


References

CONFIRM - https://bugzilla.redhat.com/show_bug.cgi?id=725951

CONFIRM - http://worldofpadman.com/website/news/en/article/266/wop-1-5-1-1-hotfix-released-for-linux.html

CONFIRM - http://thilo.tjps.eu/download/patches/ioq3-svn-r2097.diff

CONFIRM - http://svn.icculus.org/quake3?view=rev&revision=2097

XF - ioquake-idtech-command-execution(68869)

BID - 48915

BUGTRAQ - 20110728 Two security issues fixed in ioQuake3 engine

OSVDB - 74137

SREASON - 8324

SECUNIA - 45468

SECUNIA - 45417

FEDORA - FEDORA-2011-9898


Last Updated: 27 May 2016 10:56:18