Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2011-1522

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2011-1522
Last Modified 31 May 2011 12:00:00
Published 03 May 2011 04:55:06
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2011-1522

Summary

Multiple SQL injection vulnerabilities in the Doctrine\DBAL\Platforms\AbstractPlatform::modifyLimitQuery function in Doctrine 1.x before 1.2.4 and 2.x before 2.0.3 allow remote attackers to execute arbitrary SQL commands via the (1) limit or (2) offset field.

Vulnerable Systems

Application

  • Doctrine-project Doctrine 2.0.0

  • Doctrine-project Doctrine 2.0.1

  • Doctrine-project Doctrine 2.0.2

  • Doctrine-project Doctrine1.2.0

  • Doctrine-project Doctrine1.2.1

  • Doctrine-project Doctrine1.2.2

  • Doctrine-project Doctrine1.2.3


References

CONFIRM - https://bugzilla.redhat.com/show_bug.cgi?id=689396

CONFIRM - http://www.doctrine-project.org/blog/doctrine-security-fix

BID - 47034

DEBIAN - DSA-2223

MLIST - [oss-security] 20110328 Re: CVE Request -- php-doctrine-Doctrine -- SQL injection flaw

MLIST - [oss-security] 20110325 CVE Request -- php-doctrine-Doctrine -- SQL injection flaw

CONFIRM - http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=622674


Last Updated: 27 May 2016 10:56:22