Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2011-1582

Overview

Vulnerability Score 4.3 4.3
CVE Id CVE-2011-1582
Last Modified 21 Sep 2011 11:30:34
Published 20 May 2011 06:55:03
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2011-1582

Summary

Apache Tomcat 7.0.12 and 7.0.13 processes the first request to a servlet without following security constraints that have been configured through annotations, which allows remote attackers to bypass intended access restrictions via HTTP requests. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-1088, CVE-2011-1183, and CVE-2011-1419.

Vulnerable Systems

Application

  • Apache Tomcat 7.0.12

  • Apache Tomcat 7.0.13


References

BID - 47886

CONFIRM - http://svn.apache.org/viewvc?view=revision&revision=1100832

XF - tomcat-annotations-security-bypass(67515)

VUPEN - ADV-2011-1255

BUGTRAQ - 20110517 [SECURITY] CVE-2011-1582 Apache Tomcat security constraint bypass

CONFIRM - http://tomcat.apache.org/security-7.html#Fixed_in_Apache_Tomcat_7.0.14_%28released_12_May_2011%29

SREASON - 8256

MLIST - [www-announce] 20110517 [SECURITY] CVE-2011-1582 Apache Tomcat security constraint bypass


Last Updated: 27 May 2016 10:56:22