Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2011-1587

Overview

Vulnerability Score 4.3 4.3
CVE Id CVE-2011-1587
Last Modified 18 Jan 2012 10:56:56
Published 26 Apr 2011 08:55:04
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2011-1587

Summary

Cross-site scripting (XSS) vulnerability in MediaWiki before 1.16.4, when Internet Explorer 6 or earlier is used, allows remote attackers to inject arbitrary web script or HTML via an uploaded file accessed with a dangerous extension such as .html located before a ? (question mark) in a query string, in conjunction with a modified URI path that has a %2E sequence in place of the . (dot) character. NOTE: this vulnerability exists because of an incomplete fix for CVE-2011-1578.

Vulnerable Systems

Application

  • Mediawiki 1.1.0

  • Mediawiki 1.10.0

  • Mediawiki 1.10.1

  • Mediawiki 1.10.2

  • Mediawiki 1.10.3

  • Mediawiki 1.10.4

  • Mediawiki 1.11

  • Mediawiki 1.11.0

  • Mediawiki 1.11.1

  • Mediawiki 1.11.2

  • Mediawiki 1.12.0

  • Mediawiki 1.12.1

  • Mediawiki 1.12.2

  • Mediawiki 1.12.3

  • Mediawiki 1.12.4

  • Mediawiki 1.13.0

  • Mediawiki 1.13.1

  • Mediawiki 1.13.2

  • Mediawiki 1.13.3

  • Mediawiki 1.13.4

  • Mediawiki 1.14.0

  • Mediawiki 1.14.1

  • Mediawiki 1.15.0

  • Mediawiki 1.15.1

  • Mediawiki 1.15.2

  • Mediawiki 1.15.3

  • Mediawiki 1.15.4

  • Mediawiki 1.15.5

  • Mediawiki 1.16.0

  • Mediawiki 1.16.1

  • Mediawiki 1.16.2

  • Mediawiki 1.16.3

  • Mediawiki 1.2.0

  • Mediawiki 1.2.1

  • Mediawiki 1.2.2

  • Mediawiki 1.2.3

  • Mediawiki 1.2.4

  • Mediawiki 1.2.5

  • Mediawiki 1.2.6

  • Mediawiki 1.3

  • Mediawiki 1.3.0

  • Mediawiki 1.3.1

  • Mediawiki 1.3.10

  • Mediawiki 1.3.11

  • Mediawiki 1.3.12

  • Mediawiki 1.3.13

  • Mediawiki 1.3.14

  • Mediawiki 1.3.15

  • Mediawiki 1.3.2

  • Mediawiki 1.3.3

  • Mediawiki 1.3.4

  • Mediawiki 1.3.5

  • Mediawiki 1.3.6

  • Mediawiki 1.3.7

  • Mediawiki 1.3.8

  • Mediawiki 1.3.9

  • Mediawiki 1.4

  • Mediawiki 1.4.0

  • Mediawiki 1.4.1

  • Mediawiki 1.4.10

  • Mediawiki 1.4.11

  • Mediawiki 1.4.12

  • Mediawiki 1.4.13

  • Mediawiki 1.4.14

  • Mediawiki 1.4.2

  • Mediawiki 1.4.3

  • Mediawiki 1.4.4

  • Mediawiki 1.4.5

  • Mediawiki 1.4.6

  • Mediawiki 1.4.7

  • Mediawiki 1.4.8

  • Mediawiki 1.4.9

  • Mediawiki 1.5

  • Mediawiki 1.5.0

  • Mediawiki 1.5.1

  • Mediawiki 1.5.2

  • Mediawiki 1.5.3

  • Mediawiki 1.5.4

  • Mediawiki 1.5.5

  • Mediawiki 1.5.6

  • Mediawiki 1.5.7

  • Mediawiki 1.5.8

  • Mediawiki 1.6.0

  • Mediawiki 1.6.1

  • Mediawiki 1.6.10

  • Mediawiki 1.6.11

  • Mediawiki 1.6.12

  • Mediawiki 1.6.2

  • Mediawiki 1.6.3

  • Mediawiki 1.6.4

  • Mediawiki 1.6.5

  • Mediawiki 1.6.6

  • Mediawiki 1.6.7

  • Mediawiki 1.6.8

  • Mediawiki 1.6.9

  • Mediawiki 1.7.0

  • Mediawiki 1.7.1

  • Mediawiki 1.7.2

  • Mediawiki 1.7.3

  • Mediawiki 1.8.0

  • Mediawiki 1.8.1

  • Mediawiki 1.8.2

  • Mediawiki 1.8.3

  • Mediawiki 1.8.4

  • Mediawiki 1.8.5

  • Mediawiki 1.9.0

  • Mediawiki 1.9.1

  • Mediawiki 1.9.2

  • Mediawiki 1.9.3

  • Mediawiki 1.9.4

  • Mediawiki 1.9.5

  • Mediawiki 1.9.6


References

CONFIRM - https://bugzilla.redhat.com/show_bug.cgi?id=696360

MLIST - [oss-security] 20110418 Re: CVE request: mediawiki 1.16.4, incomplete fix of CVE-2011-1578

MLIST - [mediawiki-announce] 20110414 MediaWiki security release 1.16.4

DEBIAN - DSA-2366


Last Updated: 27 May 2016 10:58:04