Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2011-1843

Overview

Vulnerability Score 6.8 6.8
CVE Id CVE-2011-1843
Last Modified 06 Sep 2011 11:16:38
Published 02 May 2011 08:55:01
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2011-1843

Summary

Integer overflow in conf.c in Tinyproxy before 1.8.3 might allow remote attackers to bypass intended access restrictions in opportunistic circumstances via a TCP connection, related to improper handling of invalid port numbers.

Vulnerable Systems

Application

  • Banu Tinyproxy 1.5.0

  • Banu Tinyproxy 1.5.1

  • Banu Tinyproxy 1.5.2

  • Banu Tinyproxy 1.5.3

  • Banu Tinyproxy 1.6.0

  • Banu Tinyproxy 1.6.1

  • Banu Tinyproxy 1.6.2

  • Banu Tinyproxy 1.6.3

  • Banu Tinyproxy 1.6.4

  • Banu Tinyproxy 1.6.5

  • Banu Tinyproxy 1.7.0

  • Banu Tinyproxy 1.7.1

  • Banu Tinyproxy 1.8.0

  • Banu Tinyproxy 1.8.1

  • Banu Tinyproxy 1.8.2


References

CONFIRM - https://banu.com/cgit/tinyproxy/diff/?id=97b9984484299b2ce72f8f4fc3706dab8a3a8439

CONFIRM - https://banu.com/bugzilla/show_bug.cgi?id=90

BID - 47715


Last Updated: 27 May 2016 10:56:49