Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2011-2532

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2011-2532
Last Modified 28 Jun 2011 12:00:00
Published 22 Jun 2011 05:55:02
Confidentiality Impact NONE NONE
Integrity Impact NONE NONE
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2011-2532

Summary

The json.decode function in util/json.lua in Prosody 0.8.x before 0.8.1 might allow remote attackers to cause a denial of service (infinite loop) via invalid JSON data, as demonstrated by truncated data.

Vulnerable Systems

Application

  • Prosody 0.8.0


References

CONFIRM - http://prosody.im/doc/release/0.8.1

CONFIRM - http://hg.prosody.im/0.8/rev/20979f124ad9

CONFIRM - http://blog.prosody.im/prosody-0-8-1-released/


Last Updated: 27 May 2016 10:57:02