Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2011-2894

Overview

Vulnerability Score 6.8 6.8
CVE Id CVE-2011-2894
Last Modified 13 Feb 2012 11:08:02
Published 04 Oct 2011 06:55:09
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2011-2894

Summary

Spring Framework 3.0.0 through 3.0.5, Spring Security 3.0.0 through 3.0.5 and 2.0.0 through 2.0.6, and possibly other versions deserialize objects from untrusted sources, which allows remote attackers to bypass intended security restrictions and execute untrusted code by (1) serializing a java.lang.Proxy instance and using InvocationHandler, or (2) accessing internal AOP interfaces, as demonstrated using deserialization of a DefaultListableBeanFactory instance to execute arbitrary commands via the java.lang.Runtime class.

Vulnerable Systems

Application

  • Vmware Springsource Spring Framework 3.0.0

  • Vmware Springsource Spring Framework 3.0.1

  • Vmware Springsource Spring Framework 3.0.2

  • Vmware Springsource Spring Framework 3.0.3

  • Vmware Springsource Spring Framework 3.0.4

  • Vmware Springsource Spring Framework 3.0.5

  • Vmware Springsource Spring Security 2.0.0

  • Vmware Springsource Spring Security 2.0.1

  • Vmware Springsource Spring Security 2.0.2

  • Vmware Springsource Spring Security 2.0.3

  • Vmware Springsource Spring Security 2.0.4

  • Vmware Springsource Spring Security 2.0.5

  • Vmware Springsource Spring Security 2.0.6

  • Vmware Springsource Spring Security 3.0.0

  • Vmware Springsource Spring Security 3.0.1

  • Vmware Springsource Spring Security 3.0.2

  • Vmware Springsource Spring Security 3.0.3

  • Vmware Springsource Spring Security 3.0.4

  • Vmware Springsource Spring Security 3.0.5


References

XF - spring-framework-object-sec-bypass(69687)

CONFIRM - http://www.springsource.com/security/cve-2011-2894

BID - 49536

BUGTRAQ - 20110909 CVE-2011-2894: Spring Framework and Spring Security serialization-based remoting vulnerabilities

REDHAT - RHSA-2011:1334

OSVDB - 75263

SREASON - 8405


Last Updated: 27 May 2016 10:57:25