Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2011-3371

Overview

Vulnerability Score 4.3 4.3
CVE Id CVE-2011-3371
Last Modified 18 May 2012 12:00:00
Published 02 Oct 2011 04:55:01
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2011-3371

Summary

Multiple cross-site scripting (XSS) vulnerabilities in include/functions.php in PunBB before 1.3.6 allow remote attackers to inject arbitrary web script or HTML via the (1) id, (2) form_sent, (3) csrf_token, (4) req_confirm, or (5) delete parameter to delete.php, the (6) id, (7) form_sent, (8) csrf_token, (9) req_message, or (10) submit parameter to edit.php, the (11) action, (12) form_sent, (13) csrf_token, (14) req_email, or (15) request_pass parameter to login.php, the (16) email, (17) form_sent, (18) redirect_url, (19) csrf_token, (20) req_subject, (21) req_message, or (22) submit parameter to misc.php, the (23) action, (24) id, (25) form_sent, (26) csrf_token, (27) req_old_password, (28) req_new_password1, (29) req_new_password2, or (30) update parameter to profile.php, or the (31) action, (32) form_sent, (33) csrf_token, (34) req_username, (35) req_password1, (36) req_password2, (37) req_email1, (38) timezone, or (39) register parameter to register.php.

Vulnerable Systems

Application

  • Punbb 1.0

  • Punbb 1.0.1

  • Punbb 1.1

  • Punbb 1.1.1

  • Punbb 1.1.2

  • Punbb 1.1.3

  • Punbb 1.1.4

  • Punbb 1.1.5

  • Punbb 1.2

  • Punbb 1.2.1

  • Punbb 1.2.10

  • Punbb 1.2.11

  • Punbb 1.2.12

  • Punbb 1.2.13

  • Punbb 1.2.14

  • Punbb 1.2.15

  • Punbb 1.2.16

  • Punbb 1.2.17

  • Punbb 1.2.18

  • Punbb 1.2.19

  • Punbb 1.2.2

  • Punbb 1.2.20

  • Punbb 1.2.21

  • Punbb 1.2.22

  • Punbb 1.2.23

  • Punbb 1.2.3

  • Punbb 1.2.4

  • Punbb 1.2.5

  • Punbb 1.2.6

  • Punbb 1.2.7

  • Punbb 1.2.8

  • Punbb 1.2.9

  • Punbb 1.3

  • Punbb 1.3.1

  • Punbb 1.3.2

  • Punbb 1.3.3

  • Punbb 1.3.4

  • Punbb 1.3.5


References

CONFIRM - https://github.com/punbb/punbb/commit/dd50a50a2760f10bd2d09814e30af4b36052ca6d

CONFIRM - https://github.com/downloads/punbb/punbb/punbb-1.3.6.zip

MLIST - [oss-security] 20110922 Re: CVE request: PunBB multiple XSS issues

MLIST - [oss-security] 20110918 CVE request: PunBB multiple XSS issues

CONFIRM - http://punbb.informer.com/forums/topic/24430/punbb-136/

CONFIRM - http://punbb.informer.com/forums/topic/24427/multiple-xss-vulnerabilities/

SECTRACK - 1026073

FULLDISC - 20110922 Re: PunBB PHP Forum - Multiple XSS

FULLDISC - 20110918 Re: PunBB PHP Forum - Multiple XSS

FULLDISC - 20110916 PunBB PHP Forum - Multiple XSS


Last Updated: 27 May 2016 10:57:42