Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2011-4620

Overview

Vulnerability Score 9.3 9.3
CVE Id CVE-2011-4620
Last Modified 25 Jun 2013 11:07:10
Published 30 Dec 2011 08:55:00
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2011-4620

Summary

Buffer overflow in the ulSetError function in util/ulError.cxx in PLIB 1.8.5, as used in TORCS 1.3.1 and other products, allows user-assisted remote attackers to execute arbitrary code via vectors involving a long error message, as demonstrated by a crafted acc file for TORCS. NOTE: some of these details are obtained from third party information.

Vulnerable Systems

Application

  • Steve J Baker Plib 1.8.5


References

EXPLOIT-DB - 18258

SECUNIA - 47297

MLIST - [oss-security] 20111221 plib ulSetError() buffer overflow - CVE-2011-4620

OSVDB - 77973

SUSE - openSUSE-SU-2012:1506

SUSE - openSUSE-SU-2013:0146

SECUNIA - 51340


Last Updated: 27 May 2016 10:56:40