Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2011-1914

Overview

Vulnerability Score 10.0 10.0
CVE Id CVE-2011-1914
Last Modified 23 Feb 2012 12:00:00
Published 21 Feb 2012 08:31:55
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2011-1914

Summary

Buffer overflow in the Advantech ADAM OLE for Process Control (OPC) Server ActiveX control in ADAM OPC Server before 3.01.012, Modbus RTU OPC Server before 3.01.010, and Modbus TCP OPC Server before 3.01.010 allows remote attackers to execute arbitrary code via unspecified vectors.

Vulnerable Systems

Application

  • Advantech Adam Opc Server 3.01.011

  • Advantech Modbus Rtu Opc Server 3.01.010

  • Advantech Modbus Tcp Opc Server 3.01.09


References

MISC - http://www.us-cert.gov/control_systems/pdf/ICSA-11-279-01.pdf


Last Updated: 27 May 2016 10:38:10