Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2011-4578

Overview

Vulnerability Score 4.6 4.6
CVE Id CVE-2011-4578
Last Modified 04 Apr 2013 11:06:21
Published 29 Aug 2012 06:55:01
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector LOCAL
Access Complexity LOW
Authentication NONE

CVE-2011-4578

Summary

event.c in acpid (aka acpid2) before 2.0.11 does not have an appropriate umask setting during execution of event-handler scripts, which might allow local users to (1) perform write operations within directories created by a script, or (2) read files created by a script, via standard filesystem system calls.

Vulnerable Systems

Application

  • Tedfelix Acpid2 2.0.0

  • Tedfelix Acpid2 2.0.1

  • Tedfelix Acpid2 2.0.10

  • Tedfelix Acpid2 2.0.2

  • Tedfelix Acpid2 2.0.3

  • Tedfelix Acpid2 2.0.4

  • Tedfelix Acpid2 2.0.5

  • Tedfelix Acpid2 2.0.6

  • Tedfelix Acpid2 2.0.7

  • Tedfelix Acpid2 2.0.8

  • Tedfelix Acpid2 2.0.9


References

CONFIRM - https://bugzilla.redhat.com/show_bug.cgi?id=760984

CONFIRM - https://bugs.launchpad.net/ubuntu/+source/acpid/+bug/893821

MLIST - [oss-security] 20111206 Re: CVE request: acpid

CONFIRM - http://sourceforge.net/u/tedfelix/acpid2/ci/02d0bf29207f17996936ab652717855b15873901/tree/Changelog?force=True

MANDRIVA - MDVSA-2012:138


Last Updated: 27 May 2016 11:00:25