Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2011-4585

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2011-4585
Last Modified 20 Jul 2012 09:10:16
Published 20 Jul 2012 06:40:35
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact NONE NONE
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2011-4585

Summary

login/change_password.php in Moodle 1.9.x before 1.9.15 does not use https for the change-password form even if the httpslogin option is enabled, which allows remote attackers to obtain credentials by sniffing the network.

Vulnerable Systems

Application

  • Moodle 1.9

  • Moodle 1.9.1

  • Moodle 1.9.10

  • Moodle 1.9.11

  • Moodle 1.9.12

  • Moodle 1.9.13

  • Moodle 1.9.14

  • Moodle 1.9.2

  • Moodle 1.9.3

  • Moodle 1.9.4

  • Moodle 1.9.5

  • Moodle 1.9.6

  • Moodle 1.9.7

  • Moodle 1.9.8

  • Moodle 1.9.9


References

CONFIRM - http://git.moodle.org/gw?p=moodle.git;a=commit;h=01dd64a8c8aa95f793accea371b2392e662663c5

CONFIRM - https://bugzilla.redhat.com/show_bug.cgi?id=761248

CONFIRM - http://moodle.org/mod/forum/discuss.php?d=191752


Last Updated: 27 May 2016 10:54:54