Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2011-5164

Overview

Vulnerability Score 9.3 9.3
CVE Id CVE-2011-5164
Last Modified 17 Sep 2012 12:00:00
Published 15 Sep 2012 01:55:04
Confidentiality Impact COMPLETE COMPLETE
Integrity Impact COMPLETE COMPLETE
Availability Impact COMPLETE COMPLETE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2011-5164

Summary

Stack-based buffer overflow in VanDyke Software AbsoluteFTP 1.9.6 through 2.2.10 allows remote FTP servers to execute arbitrary code via a crafted file name in a LIST command response.

Vulnerable Systems

Application

  • Vandyke Absoluteftp 1.9.6

  • Vandyke Absoluteftp 2.0.3

  • Vandyke Absoluteftp 2.0.4

  • Vandyke Absoluteftp 2.0.5

  • Vandyke Absoluteftp 2.2.1

  • Vandyke Absoluteftp 2.2.10

  • Vandyke Absoluteftp 2.2.2

  • Vandyke Absoluteftp 2.2.3

  • Vandyke Absoluteftp 2.2.4

  • Vandyke Absoluteftp 2.2.5

  • Vandyke Absoluteftp 2.2.6

  • Vandyke Absoluteftp 2.2.7

  • Vandyke Absoluteftp 2.2.8

  • Vandyke Absoluteftp 2.2.9


References

BID - 50614

MISC - http://www.saintcorporation.com/cgi-bin/exploit_info/vandyke_absoluteftp_list_client_overflow

OSVDB - 77105

EXPLOIT-DB - 18102

SECUNIA - 46781


Last Updated: 27 May 2016 10:55:02