Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-0908

Overview

Vulnerability Score 4.3 4.3
CVE Id CVE-2012-0908
Last Modified 25 Jan 2012 10:21:01
Published 24 Jan 2012 01:55:01
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2012-0908

Summary

Cross-site scripting (XSS) vulnerability in logout.php in SimpleSAMLphp 1.8.1 and possibly other versions before 1.8.2 allows remote attackers to inject arbitrary web script or HTML via the link_href parameter.

Vulnerable Systems

Application

  • Simplesamlphp 0.4

  • Simplesamlphp 0.5

  • Simplesamlphp 1.0

  • Simplesamlphp 1.1

  • Simplesamlphp 1.2

  • Simplesamlphp 1.3

  • Simplesamlphp 1.4

  • Simplesamlphp 1.5

  • Simplesamlphp 1.5.1

  • Simplesamlphp 1.6

  • Simplesamlphp 1.6.1

  • Simplesamlphp 1.6.2

  • Simplesamlphp 1.6.3

  • Simplesamlphp 1.7

  • Simplesamlphp 1.8

  • Simplesamlphp 1.8.1


References

XF - simplesamlphp-nocookie-logout-xss(72313)

BID - 51372

MLIST - [oss-security] 20120120 Re: CVE request: simpleSAMLphp 1.8.2 cross site scripting

SECUNIA - 47491

OSVDB - 78255

CONFIRM - http://code.google.com/p/simplesamlphp/issues/detail?id=468


Last Updated: 27 May 2016 10:57:23