Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-0962

Overview

Vulnerability Score 4.3 4.3
CVE Id CVE-2012-0962
Last Modified 27 Dec 2012 01:42:03
Published 26 Dec 2012 05:55:02
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2012-0962

Summary

Aptdaemon 0.43 in Ubuntu 11.10 and 12.04 LTS uses short IDs when importing PPA GPG keys from a keyserver, which allows remote attackers to install arbitrary package repository GPG keys via a man-in-the-middle (MITM) attack.

Vulnerable Systems

Operating System

  • Canonical Ubuntu Linux 11.10

  • Canonical Ubuntu Linux 12.04

Application

  • Sebastian Heinlein Aptdaemon 0.43


References

CONFIRM - https://bugs.launchpad.net/software-center-agent/%2Bbug/1052789

UBUNTU - USN-1666-1

SECTRACK - 1027891

BID - 56959

SECUNIA - 51627


Last Updated: 27 May 2016 11:01:30