Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-1068

Overview

Vulnerability Score 4.3 4.3
CVE Id CVE-2012-1068
Last Modified 15 Feb 2012 10:45:14
Published 14 Feb 2012 12:55:02
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2012-1068

Summary

Cross-site scripting (XSS) vulnerability in the rc_ajax function in core.php in the WP-RecentComments plugin before 2.0.7 for WordPress allows remote attackers to inject arbitrary web script or HTML via the page parameter, related to AJAX paging.

Vulnerable Systems

Application

  • Mg12 Wp-recentcomments 1.8

  • Mg12 Wp-recentcomments 1.8.1

  • Mg12 Wp-recentcomments 1.8.2

  • Mg12 Wp-recentcomments 2.0

  • Mg12 Wp-recentcomments 2.0.1

  • Mg12 Wp-recentcomments 2.0.2

  • Mg12 Wp-recentcomments 2.0.3

  • Mg12 Wp-recentcomments 2.0.4

  • Mg12 Wp-recentcomments 2.0.5

  • Mg12 Wp-recentcomments 2.0.6

  • Mg12 Wp-recentcomments 2.0.7


References

XF - wprecentcomments-core-xss(70003)

BID - 49734

OSVDB - 75635

CONFIRM - http://wordpress.org/extend/plugins/wp-recentcomments/changelog/

SECUNIA - 46141

CONFIRM - http://plugins.trac.wordpress.org/changeset/416723/wp-recentcomments/trunk/core.php?old=316325&old_path=wp-recentcomments%2Ftrunk%2Fcore.php


Last Updated: 27 May 2016 10:57:26