Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-1578

Overview

Vulnerability Score 6.8 6.8
CVE Id CVE-2012-1578
Last Modified 29 Jan 2013 11:48:59
Published 09 Sep 2012 05:55:05
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2012-1578

Summary

Multiple cross-site request forgery (CSRF) vulnerabilities in MediaWiki 1.17.x before 1.17.3 and 1.18.x before 1.18.2 allow remote attackers to hijack the authentication of users with the block permission for requests that (1) block a user via a request to the Block module or (2) unblock a user via a request to the Unblock module.

Vulnerable Systems

Application

  • Mediawiki 1.17

  • Mediawiki 1.17.0

  • Mediawiki 1.17.1

  • Mediawiki 1.17.2

  • Mediawiki 1.18

  • Mediawiki 1.18.0

  • Mediawiki 1.18.1


References

CONFIRM - https://bugzilla.wikimedia.org/show_bug.cgi?id=34212

BID - 52689

MLIST - [oss-security] 20120323 CVEs for MediaWiki security and maintenance release 1.18.2

MLIST - [oss-security] 20120322 MediaWiki security and maintenance release 1.18.2

SECUNIA - 48504

OSVDB - 80361

MLIST - [MediaWiki-announce] 20120322 MediaWiki security and maintenance release 1.18.2

MLIST - [MediaWiki-announce] 20120322 MediaWiki security and maintenance release 1.17.3

XF - mediawiki-multiple-csrf(78911)


Last Updated: 27 May 2016 11:00:32