Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-1584

Overview

Vulnerability Score 4.3 4.3
CVE Id CVE-2012-1584
Last Modified 29 Jan 2013 11:49:00
Published 06 Sep 2012 02:55:01
Confidentiality Impact NONE NONE
Integrity Impact NONE NONE
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2012-1584

Summary

Integer overflow in the mid function in toolkit/tbytevector.cpp in TagLib 1.7 and earlier allows context-dependent attackers to cause a denial of service (application crash) via a crafted file header field in a media file, which triggers a large memory allocation.

Vulnerable Systems

Application

  • Scott Wheeler Taglib 1.0

  • Scott Wheeler Taglib 1.1

  • Scott Wheeler Taglib 1.2

  • Scott Wheeler Taglib 1.3

  • Scott Wheeler Taglib 1.3.1

  • Scott Wheeler Taglib 1.4

  • Scott Wheeler Taglib 1.5

  • Scott Wheeler Taglib 1.6

  • Scott Wheeler Taglib 1.6.1

  • Scott Wheeler Taglib 1.6.2

  • Scott Wheeler Taglib 1.6.3

  • Scott Wheeler Taglib 1.7


References

CONFIRM - https://github.com/taglib/taglib/commit/dcdf4fd954e3213c355746fa15b7480461972308

BID - 52290

MLIST - [oss-security] 20120326 Re: CVE-Request taglib vulnerabilities

MLIST - [oss-security] 20120321 Re: CVE-Request taglib vulnerabilities

MLIST - [oss-security] 20120305 Re: CVE-Request taglib vulnerabilities

GENTOO - GLSA-201206-16

SECUNIA - 49688

SECUNIA - 48211

MLIST - [pipermail] 20120305 multiple security vulnerabilities in taglib

MLIST - [pipermail] 20120304 multiple security vulnerabilities in taglib

SECUNIA - 48792

XF - taglib-mid-dos(78909)

Related Patches

Novell SUSE 2012:6179 taglib security update for SLE 11 SP1 i586

Novell SUSE 2012:6179 taglib security update for SLE 11 SP1 x86_64

Novell SUSE 2012:8041 taglib security update for SLE 10 SP4 i586

Novell SUSE 2012:8041 taglib security update for SLE 10 SP4 x86_64


Last Updated: 27 May 2016 11:00:30