Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-1652

Overview

Vulnerability Score 2.1 2.1
CVE Id CVE-2012-1652
Last Modified 20 Sep 2012 12:00:00
Published 19 Sep 2012 03:55:04
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity HIGH
Authentication SINGLE_INSTANCE

CVE-2012-1652

Summary

Cross-site scripting (XSS) vulnerability in the Hierarchical Select module 6.x-3.x before 6.x-3.8 for Drupal allows remote authenticated users with administer taxonomy permissions to inject arbitrary web script or HTML via unspecified vectors related to "the vocabulary's help text."

Vulnerable Systems

Application

  • Wim Leers Hierarchical Select 6.x-3.0

  • Wim Leers Hierarchical Select 6.x-3.1

  • Wim Leers Hierarchical Select 6.x-3.2

  • Wim Leers Hierarchical Select 6.x-3.3

  • Wim Leers Hierarchical Select 6.x-3.4

  • Wim Leers Hierarchical Select 6.x-3.5

  • Wim Leers Hierarchical Select 6.x-3.6

  • Wim Leers Hierarchical Select 6.x-3.7

  • Wim Leers Hierarchical Select 6.x-3.x

  • Wimleers Hierarchical Select 6.x-3.0

  • Wimleers Hierarchical Select 6.x-3.1

  • Wimleers Hierarchical Select 6.x-3.x


References

XF - hierarchicalselect-textvocabularies-xss(73611)

BID - 52228

MLIST - [oss-security] 20120406 CVE's for Drupal Contrib 2012 001 through 057 (67 new CVE assignments)

SECUNIA - 48235

OSVDB - 79683

CONFIRM - http://drupalcode.org/project/hierarchical_select.git/commit/be32dceb17d25553e474c295a8c3db69eab95cee

CONFIRM - http://drupal.org/node/1461724

CONFIRM - http://drupal.org/node/1461318


Last Updated: 27 May 2016 11:00:46