Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-1654

Overview

Vulnerability Score 2.1 2.1
CVE Id CVE-2012-1654
Last Modified 20 Dec 2012 12:00:00
Published 18 Sep 2012 04:55:01
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity HIGH
Authentication SINGLE_INSTANCE

CVE-2012-1654

Summary

Multiple cross-site scripting (XSS) vulnerabilities in the Data module 6.x-1.x before 6.x-1.0 and 7.x-1.x before 7.x-1.0-alpha3 for Drupal allow remote authenticated users with the administer data tables permission to inject arbitrary web script or HTML via the title parameter in (1) data.views.inc and (2) data_ui/data_ui.admin.inc.

Vulnerable Systems

Application

  • Alex Barth Data 6.x-1.0

  • Alex Barth Data 6.x-1.x

  • Alex Barth Data 7.x-1.0

  • Alex Barth Data 7.x-1.x


References

BID - 52337

OSVDB - 79854

MLIST - [oss-security] 20120406 CVE's for Drupal Contrib 2012 001 through 057 (67 new CVE assignments)

MISC - http://www.madirish.net/content/drupal-data-6x-10-xss-vulnerability

SECUNIA - 48326

CONFIRM - http://drupalcode.org/project/data.git/commit/6f6858a

CONFIRM - http://drupalcode.org/project/data.git/commit/33f0caa

MISC - http://drupal.org/node/1471780

CONFIRM - http://drupal.org/node/1470982

CONFIRM - http://drupal.org/node/1470980


Last Updated: 27 May 2016 11:00:44