Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-1657

Overview

Vulnerability Score 2.1 2.1
CVE Id CVE-2012-1657
Last Modified 20 Dec 2012 12:00:00
Published 18 Sep 2012 04:55:01
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity HIGH
Authentication SINGLE_INSTANCE

CVE-2012-1657

Summary

Cross-site scripting (XSS) vulnerability in block_class.module in the Block Class module before 7.x-1.1 for Drupal allows remote authenticated users with certain permissions to inject arbitrary web script or HTML via the class name.

Vulnerable Systems

Application

  • Fourkitchens Block Class 5.x-1.0

  • Fourkitchens Block Class 5.x-1.1

  • Fourkitchens Block Class 5.x-1.x

  • Fourkitchens Block Class 6.x-1.0

  • Fourkitchens Block Class 6.x-1.1

  • Fourkitchens Block Class 6.x-1.2

  • Fourkitchens Block Class 6.x-1.3

  • Fourkitchens Block Class 6.x-1.4

  • Fourkitchens Block Class 6.x-1.x

  • Fourkitchens Block Class 6.x-2.x

  • Fourkitchens Block Class 7.x-1.0

  • Fourkitchens Block Class 7.x-1.x


References

XF - blockclass-addmod-class-xss(73776)

BID - 52341

OSVDB - 79851

MLIST - [oss-security] 20120406 CVE's for Drupal Contrib 2012 001 through 057 (67 new CVE assignments)

SECUNIA - 48298

CONFIRM - http://drupalcode.org/project/block_class.git/commit/9a5205d

MISC - http://drupal.org/node/1471808

CONFIRM - http://drupal.org/node/1471090


Last Updated: 27 May 2016 11:00:44