Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-1833

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2012-1833
Last Modified 01 Mar 2013 11:40:50
Published 28 Sep 2012 05:55:01
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2012-1833

Summary

VMware SpringSource Grails before 1.3.8, and 2.x before 2.0.2, does not properly restrict data binding, which might allow remote attackers to bypass intended access restrictions and modify arbitrary object properties via a crafted request parameter to an application.

Vulnerable Systems

Application

  • Springsource Grails 1.1.0

  • Springsource Grails 1.1.1

  • Springsource Grails 1.1.2

  • Springsource Grails 1.2.0

  • Springsource Grails 1.2.1

  • Springsource Grails 1.2.2

  • Springsource Grails 1.3.0

  • Springsource Grails 1.3.1

  • Springsource Grails 1.3.2

  • Springsource Grails 1.3.3

  • Springsource Grails 1.3.4

  • Springsource Grails 1.3.5

  • Springsource Grails 1.3.6

  • Springsource Grails 1.3.7

  • Springsource Grails 2.0

  • Springsource Grails 2.0.1


References

CONFIRM - http://support.springsource.com/security/cve-2012-1833

BID - 55763

SECUNIA - 51113


Last Updated: 27 May 2016 11:00:49