Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-1910

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2012-1910
Last Modified 07 Aug 2012 12:00:00
Published 06 Aug 2012 12:55:01
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2012-1910

Summary

Bitcoin-Qt 0.5.0.x before 0.5.0.5; 0.5.1.x, 0.5.2.x, and 0.5.3.x before 0.5.3.1; and 0.6.x before 0.6.0rc4 on Windows does not use MinGW multithread-safe exception handling, which allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via crafted Bitcoin protocol messages.

Vulnerable Systems

Application

  • Bitcoin-qt 0.5.0

  • Bitcoin-qt 0.5.0.4

  • Bitcoin-qt 0.5.1

  • Bitcoin-qt 0.5.2

  • Bitcoin-qt 0.5.3.0

  • Bitcoin-qt 0.6.0


References

CONFIRM - https://github.com/bitcoin/bitcoin/commit/8864019f6d88b13d3442843d9e6ebeb8dd938831

CONFIRM - https://en.bitcoin.it/wiki/CVEs

CONFIRM - https://bitcointalk.org/index.php?topic=69120.0

CONFIRM - http://gavintech.blogspot.com/2012/03/full-disclosure-bitcoin-qt-on-windows.html


Last Updated: 27 May 2016 10:57:34