Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-2070

Overview

Vulnerability Score 2.1 2.1
CVE Id CVE-2012-2070
Last Modified 29 Aug 2012 12:00:00
Published 14 Aug 2012 07:55:01
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity HIGH
Authentication SINGLE_INSTANCE

CVE-2012-2070

Summary

Cross-site scripting (XSS) vulnerability in the MultiBlock module 6.x-1.x before 6.x-1.4 and 7.x-1.x before 7.x-1.1 for Drupal allows remote authenticated users with the administer blocks permission to inject arbitrary web script or HTML via the block title.

Vulnerable Systems

Application

  • Andrew Levine Multiblock 6.x-1.1

  • Andrew Levine Multiblock 6.x-1.2

  • Andrew Levine Multiblock 6.x-1.3

  • Andrew Levine Multiblock 6.x-1.x

  • Andrew Levine Multiblock 6.x-1.x-dev

  • Andrew Levine Multiblock 7.x-1.0

  • Andrew Levine Multiblock 7.x-1.x

  • Andrew Levine Multiblock 7.x-1.x-dev


References

XF - multiblock-blocktitle-xss(74466)

BID - 52800

MLIST - [oss-security] 20120406 CVE's for Drupal Contrib 2012 001 through 057 (67 new CVE assignments)

MISC - http://www.madirish.net/content/drupal-multiblock-6x-13-xss-vulnerability

SECUNIA - 48588

OSVDB - 80673

CONFIRM - http://drupalcode.org/project/multiblock.git/commit/aee07d3

CONFIRM - http://drupalcode.org/project/multiblock.git/commit/2c5177b

MISC - http://drupal.org/node/1506390

CONFIRM - http://drupal.org/node/1505414

CONFIRM - http://drupal.org/node/1505410


Last Updated: 27 May 2016 10:49:39