Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-2097

Overview

Vulnerability Score 6.8 6.8
CVE Id CVE-2012-2097
Last Modified 18 Dec 2012 11:52:40
Published 14 Aug 2012 05:55:01
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2012-2097

Summary

Cross-site request forgery (CSRF) vulnerability in the Autosave module 6.x before 6.x-2.10 and 7.x-2.x before 7.x-2.0 for Drupal allows remote attackers to hijack the authentication of arbitrary users for requests involving "submitting saved results to a node."

Vulnerable Systems

Application

  • Larry Garfield Autosave 6.x-2.0

  • Larry Garfield Autosave 6.x-2.1

  • Larry Garfield Autosave 6.x-2.2

  • Larry Garfield Autosave 6.x-2.3

  • Larry Garfield Autosave 6.x-2.4

  • Larry Garfield Autosave 6.x-2.5

  • Larry Garfield Autosave 6.x-2.6

  • Larry Garfield Autosave 6.x-2.7

  • Larry Garfield Autosave 6.x-2.8

  • Larry Garfield Autosave 6.x-2.9

  • Larry Garfield Autosave 6.x-2.x

  • Larry Garfield Autosave 6.x-2.x-dev

  • Larry Garfield Autosave 7.x-2.x

  • Larry Garfield Autosave 7.x-2.x-dev


References

BID - 52985

MLIST - [oss-security] 20120411 Re: CVE Request for Drupal Contributed Advisories on 2012-04-11

MLIST - [oss-security] 20120411 CVE Request for Drupal Contributed Advisories on 2012-04-11

CONFIRM - http://drupalcode.org/project/autosave.git/commitdiff/f7bfd2d

CONFIRM - http://drupalcode.org/project/autosave.git/commitdiff/39f7fb0

CONFIRM - http://drupal.org/node/1528906

MISC - http://drupal.org/node/1528864

CONFIRM - http://drupal.org/node/1525998

XF - autosave-savedresults-csrf(74838)


Last Updated: 27 May 2016 10:49:39