Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-2114

Overview

Vulnerability Score 7.5 7.5
CVE Id CVE-2012-2114
Last Modified 18 Dec 2012 11:52:43
Published 31 Aug 2012 06:55:01
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2012-2114

Summary

Stack-based buffer overflow in fprintf in musl before 0.8.8 and earlier allows context-dependent attackers to cause a denial of service (crash) or possibly execute arbitrary code via a long string to an unbuffered stream such as stderr.

Vulnerable Systems

Application

  • Etalabs Musl 0.8.8


References

MLIST - [oss-security] 20120418 Re: Stack-based buffer overflow in musl libc 0.8.7 and earlier

MLIST - [oss-security] 20120418 Stack-based buffer overflow in musl libc 0.8.7 and earlier

MLIST - [musl] 20120417 musl security advisory #001: stack buffer overflow in vfprintf with long output

CONFIRM - http://www.etalabs.net/musl/download.html

BID - 53144


Last Updated: 27 May 2016 11:00:26