Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-2132

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2012-2132
Last Modified 14 Feb 2013 11:56:44
Published 20 Aug 2012 02:55:03
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2012-2132

Summary

libsoup 2.32.2 and earlier does not validate certificates or clear the trust flag when the ssl-ca-file does not exist, which allows remote attackers to bypass authentication by connecting with a SSL connection.

Vulnerable Systems

Application

  • Gnome Libsoup 2.32.2


References

CONFIRM - https://bugzilla.gnome.org/show_bug.cgi?id=666280

MLIST - [oss-security] 20120502 Re: CVE Request: libsoup 2.32.2 sets ssl trusted flag despite no verification

MLIST - [oss-security] 20120430 Re: CVE Request: libsoup 2.32.2 sets ssl trusted flag despite no verification

MLIST - [oss-security] 20120424 CVE Request: libsoup 2.32.2 sets ssl trusted flag despite no verification

MLIST - [oss-security] 20120424 Re: CVE Request: libsoup 2.32.2 sets ssl trusted flag despite no verification

XF - libsoup-ssl-poofing(75167)

BID - 53232

Related Patches

Novell SUSE 2012:6520 libsoup security update for SLE 11 SP2 i586

Novell SUSE 2012:6520 libsoup security update for SLE 11 SP2 x86_64


Last Updated: 27 May 2016 10:57:35