Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-2138

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2012-2138
Last Modified 10 Jul 2012 12:00:00
Published 09 Jul 2012 06:55:01
Confidentiality Impact NONE NONE
Integrity Impact NONE NONE
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2012-2138

Summary

The @CopyFrom operation in the POST servlet in the org.apache.sling.servlets.post bundle before 2.1.2 in Apache Sling does not prevent attempts to copy an ancestor node to a descendant node, which allows remote attackers to cause a denial of service (infinite loop) via a crafted HTTP request.

Vulnerable Systems

Application

  • Org.apache.sling.servlets.post 2.1.0


References

CONFIRM - https://issues.apache.org/jira/browse/SLING-2517

CONFIRM - http://svn.apache.org/viewvc?view=revision&revision=1352865

MLIST - [www-announce] 20120706 [SECURITY] CVE-2012-2138 Apache Sling denial of service vulnerability


Last Updated: 27 May 2016 10:56:36