Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-2331

Overview

Vulnerability Score 4.3 4.3
CVE Id CVE-2012-2331
Last Modified 14 Aug 2012 12:00:00
Published 13 Aug 2012 07:55:02
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2012-2331

Summary

Cross-site scripting (XSS) vulnerability in serendipity/serendipity_admin_image_selector.php in Serendipity before 1.6.1 allows remote attackers to inject arbitrary web script or HTML via the serendipity[textarea] parameter. NOTE: this issue might be resultant from cross-site request forgery (CSRF).

Vulnerable Systems

Application

  • S9y Serendipity 0.3

  • S9y Serendipity 0.4

  • S9y Serendipity 0.7

  • S9y Serendipity 0.7.1

  • S9y Serendipity 0.8

  • S9y Serendipity 0.8.1

  • S9y Serendipity 0.8.2

  • S9y Serendipity 0.8.3

  • S9y Serendipity 0.8.4

  • S9y Serendipity 0.8.5

  • S9y Serendipity 0.9

  • S9y Serendipity 0.9.1

  • S9y Serendipity 1.0

  • S9y Serendipity 1.0.1

  • S9y Serendipity 1.0.2

  • S9y Serendipity 1.0.3

  • S9y Serendipity 1.0.4

  • S9y Serendipity 1.1

  • S9y Serendipity 1.1.1

  • S9y Serendipity 1.1.2

  • S9y Serendipity 1.1.3

  • S9y Serendipity 1.1.4

  • S9y Serendipity 1.2

  • S9y Serendipity 1.2.1

  • S9y Serendipity 1.3

  • S9y Serendipity 1.3.1

  • S9y Serendipity 1.4

  • S9y Serendipity 1.4.1

  • S9y Serendipity 1.5.1

  • S9y Serendipity 1.5.2

  • S9y Serendipity 1.5.3

  • S9y Serendipity 1.5.4

  • S9y Serendipity 1.5.5

  • S9y Serendipity 1.6

  • S9y Serendipity 1.6.1


References

CONFIRM - https://github.com/s9y/Serendipity/commit/264bf55719baacc069ff9d3cc35f0c349cde11e3

BID - 53418

MISC - http://www.rul3z.de/index.php?/214-KORAMISADV2012-001-Serendipity-1.6-Backend-Cross-Site-Scripting-and-SQL-Injection-vulnerability.html

MLIST - [oss-security] 20120508 Re: CVE request: XSS and SQL injection in serendipity before 1.7.1

MLIST - [oss-security] 20120508 CVE request: XSS and SQL injection in serendipity before 1.7.1

MISC - http://www.koramis.com/advisories/2012/KORAMIS-ADV2012-001.txt

SECUNIA - 49009

CONFIRM - http://blog.s9y.org/archives/240-Serendipity-1.6.1-released.html

BUGTRAQ - 20120508 Serendipity 1.6 Backend Cross-Site Scripting and SQL-Injection vulnerability


Last Updated: 27 May 2016 10:53:36