Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-2354

Overview

Vulnerability Score 4.0 4.0
CVE Id CVE-2012-2354
Last Modified 23 Jul 2012 09:50:45
Published 20 Jul 2012 11:38:55
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact NONE NONE
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity LOW
Authentication SINGLE_INSTANCE

CVE-2012-2354

Summary

Moodle 2.1.x before 2.1.6 and 2.2.x before 2.2.3 allows remote authenticated users to bypass the moodle/site:readallmessages capability requirement and read arbitrary messages by using the "Recent conversations" feature with a modified parameter in a URL.

Vulnerable Systems

Application

  • Moodle 2.1

  • Moodle 2.1.1

  • Moodle 2.1.2

  • Moodle 2.1.3

  • Moodle 2.1.4

  • Moodle 2.1.5

  • Moodle 2.2

  • Moodle 2.2.1

  • Moodle 2.2.2


References

MLIST - [oss-security] 20120523 Moodle security notifications public

CONFIRM - http://git.moodle.org/gw?p=moodle.git;a=commit;h=48e03792ca8faa2d781f9ef74606f3b3f0d3baec


Last Updated: 27 May 2016 10:54:56