Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-2676

Overview

Vulnerability Score 4.3 4.3
CVE Id CVE-2012-2676
Last Modified 30 Jul 2012 12:00:00
Published 25 Jul 2012 03:55:02
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2012-2676

Summary

Multiple integer overflows in the (1) malloc and (2) calloc functions in Hoard before 3.9 make it easier for context-dependent attackers to perform memory-related attacks such as buffer overflows on implementing code via a large size value, which causes less memory to be allocated than expected.

Vulnerable Systems

Application

  • Emery Berger Hoard 3.8


References

CONFIRM - https://github.com/emeryberger/Hoard/blob/master/NEWS

MLIST - [oss-security] 20120607 Re: memory allocator upstream patches

MLIST - [oss-security] 20120605 memory allocator upstream patches

MISC - http://kqueue.org/blog/2012/03/05/memory-allocator-security-revisited/


Last Updated: 27 May 2016 10:54:58