Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-2707

Overview

Vulnerability Score 5.8 5.8
CVE Id CVE-2012-2707
Last Modified 24 Aug 2012 11:27:29
Published 26 Jun 2012 08:55:04
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2012-2707

Summary

The Hostmaster (Aegir) module 6.x-1.x before 6.x-1.9 for Drupal does not properly exit when users do not have access to package/task nodes, which allows remote attackers to bypass intended access restrictions and edit unauthorized nodes.

Vulnerable Systems

Application

  • Antoine Beaupre Hostmaster 6.x-1.2

  • Antoine Beaupre Hostmaster 6.x-1.3

  • Antoine Beaupre Hostmaster 6.x-1.4

  • Antoine Beaupre Hostmaster 6.x-1.5

  • Antoine Beaupre Hostmaster 6.x-1.6

  • Antoine Beaupre Hostmaster 6.x-1.7

  • Antoine Beaupre Hostmaster 6.x-1.8

  • Antoine Beaupre Hostmaster 6.x-1.x


References

BID - 53588

MLIST - [oss-security] 20120613 Re: CVE Request for Drupal contributed modules

CONFIRM - http://drupalcode.org/project/hostmaster.git/commitdiff/8a61101

MISC - http://drupal.org/node/1585678

CONFIRM - http://drupal.org/node/1585658

CONFIRM - http://community.aegirproject.org/1.9

XF - hostmaster-node-security-bypass(75715)


Last Updated: 27 May 2016 10:56:35