Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-2722

Overview

Vulnerability Score 4.3 4.3
CVE Id CVE-2012-2722
Last Modified 27 Jun 2012 12:00:00
Published 26 Jun 2012 08:55:05
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact NONE NONE
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2012-2722

Summary

The node selection interface in the WYSIWYG editor (CKEditor) in the Node Embed module 6.x-1.x before 6.x-1.5 and 7.x-1.x before 7.x-1.0 for Drupal does not properly check permissions, which allows remote attackers to bypass intended access restrictions and read node titles.

Vulnerable Systems

Application

  • Scott Reynen Node Embed 6.x-1.0

  • Scott Reynen Node Embed 6.x-1.1

  • Scott Reynen Node Embed 6.x-1.2

  • Scott Reynen Node Embed 6.x-1.3

  • Scott Reynen Node Embed 6.x-1.4

  • Scott Reynen Node Embed 7.x-1.0

  • Scott Reynen Node Embed 7.x-1.x


References

XF - nodeembed-selectembed-security-bypass(76148)

BID - 53835

OSVDB - 82735

MLIST - [oss-security] 20120613 Re: CVE Request for Drupal contributed modules

SECUNIA - 48348

CONFIRM - http://drupalcode.org/project/node_embed.git/commitdiff/d06f022

CONFIRM - http://drupalcode.org/project/node_embed.git/commitdiff/7a2296c

MISC - http://drupal.org/node/1619824

CONFIRM - http://drupal.org/node/1618430

CONFIRM - http://drupal.org/node/1618428


Last Updated: 27 May 2016 10:56:35