Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-2728

Overview

Vulnerability Score 6.8 6.8
CVE Id CVE-2012-2728
Last Modified 27 Jun 2012 12:00:00
Published 26 Jun 2012 08:55:05
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2012-2728

Summary

Multiple cross-site request forgery (CSRF) vulnerabilities in the Node Hierarchy module 6.x-1.x before 6.x-1.5 for Drupal allow remote attackers to hijack the authentication of administrators for requests that change a node hierarchy position via an (1) up or (2) down action.

Vulnerable Systems

Application

  • Ronan Dowling Node Hierarchy 6.x-1.0

  • Ronan Dowling Node Hierarchy 6.x-1.1

  • Ronan Dowling Node Hierarchy 6.x-1.2

  • Ronan Dowling Node Hierarchy 6.x-1.3

  • Ronan Dowling Node Hierarchy 6.x-1.4

  • Ronan Dowling Node Hierarchy 6.x-1.x


References

XF - drupal-nodehierarchy-unspecified-csrf(76345)

BID - 53993

MLIST - [oss-security] 20120613 Re: CVE Request for Drupal contributed modules

CONFIRM - http://drupalcode.org/project/nodehierarchy.git/commitdiff/8b4b3f5

MISC - http://drupal.org/node/1632900

CONFIRM - http://drupal.org/node/1632432


Last Updated: 27 May 2016 10:56:35