Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-3418

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2012-3418
Last Modified 08 Oct 2013 03:24:48
Published 27 Aug 2012 07:55:02
Confidentiality Impact NONE NONE
Integrity Impact NONE NONE
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2012-3418

Summary

libpcp in Performance Co-Pilot (PCP) before 3.6.5 allows remote attackers to cause a denial of service and possibly execute arbitrary code via (1) a PDU with the numcreds field value greater than the number of actual elements to the __pmDecodeCreds function in p_creds.c; (2) the string byte number value to the __pmDecodeNameList function in p_pmns.c; (3) the numids value to the __pmDecodeIDList function in p_pmns.c; (4) unspecified vectors to the __pmDecodeProfile function in p_profile.c; the (5) status number value or (6) string number value to the __pmDecodeNameList function in p_pmns.c; (7) certain input to the __pmDecodeResult function in p_result.c; (8) the name length field (namelen) to the DecodeNameReq function in p_pmns.c; (9) a crafted PDU_FETCH request to the __pmDecodeFetch function in p_fetch.c; (10) the namelen field in the __pmDecodeInstanceReq function in p_instance.c; (11) the buflen field to the __pmDecodeText function in p_text.c; (12) PDU_INSTANCE packets to the __pmDecodeInstance in p_instance.c; or the (13) c_numpmid or (14) v_numval fields to the __pmDecodeLogControl function in p_lcontrol.c, which triggers integer overflows, heap-based buffer overflows, and/or buffer over-reads.

Vulnerable Systems

Application

  • Sgi Performance Co-pilot 2.1.1

  • Sgi Performance Co-pilot 2.1.10

  • Sgi Performance Co-pilot 2.1.11

  • Sgi Performance Co-pilot 2.1.2

  • Sgi Performance Co-pilot 2.1.3

  • Sgi Performance Co-pilot 2.1.4

  • Sgi Performance Co-pilot 2.1.5

  • Sgi Performance Co-pilot 2.1.6

  • Sgi Performance Co-pilot 2.1.7

  • Sgi Performance Co-pilot 2.1.8

  • Sgi Performance Co-pilot 2.1.9

  • Sgi Performance Co-pilot 2.2

  • Sgi Performance Co-pilot 3.6.4


References

MISC - https://bugzilla.redhat.com/show_bug.cgi?id=841698

MISC - https://bugzilla.redhat.com/show_bug.cgi?id=841284

MISC - https://bugzilla.redhat.com/show_bug.cgi?id=841249

MISC - https://bugzilla.redhat.com/show_bug.cgi?id=841240

MISC - https://bugzilla.redhat.com/show_bug.cgi?id=841183

MISC - https://bugzilla.redhat.com/show_bug.cgi?id=841180

MISC - https://bugzilla.redhat.com/show_bug.cgi?id=841159

MISC - https://bugzilla.redhat.com/show_bug.cgi?id=841126

MISC - https://bugzilla.redhat.com/show_bug.cgi?id=841112

MISC - https://bugzilla.redhat.com/show_bug.cgi?id=840920

MISC - https://bugzilla.redhat.com/show_bug.cgi?id=840822

MLIST - [oss-security] 20120816 pcp: Multiple security flaws

CONFIRM - http://oss.sgi.com/cgi-bin/gitweb.cgi?p=pcp/pcp.git;a=commitdiff;h=f0eaefe046b1061797f45b0c20bb2ac371b504a5

CONFIRM - http://oss.sgi.com/cgi-bin/gitweb.cgi?p=pcp/pcp.git;a=commitdiff;h=cced6012b4b93bfb640a9678589ced5416743910

CONFIRM - http://oss.sgi.com/cgi-bin/gitweb.cgi?p=pcp/pcp.git;a=commitdiff;h=bfb3ab8c6b3d75b1a6580feee76a7d0925a3633c

CONFIRM - http://oss.sgi.com/cgi-bin/gitweb.cgi?p=pcp/pcp.git;a=commitdiff;h=9f4e392c97ce42744ec73f82268ce6c815fdca0e

CONFIRM - http://oss.sgi.com/cgi-bin/gitweb.cgi?p=pcp/pcp.git;a=commitdiff;h=7eb479b91ef12bf89a15b078af2107c8c4746a4a

CONFIRM - http://oss.sgi.com/cgi-bin/gitweb.cgi?p=pcp/pcp.git;a=commitdiff;h=49c679c44425915a8d6aa4af5f90b35384843c12

CONFIRM - http://oss.sgi.com/cgi-bin/gitweb.cgi?p=pcp/pcp.git;a=commit;h=f190942b552aa80d59bbe718866aa00b8e3fd5cc

CONFIRM - http://oss.sgi.com/cgi-bin/gitweb.cgi?p=pcp/pcp.git;a=commit;h=e4faa1f0ba29151340920d975fc7639adf8371d5

CONFIRM - http://oss.sgi.com/cgi-bin/gitweb.cgi?p=pcp/pcp.git;a=commit;h=babd6c5c527f87ec838c13a1b4eba612af6ea27c

CONFIRM - http://oss.sgi.com/cgi-bin/gitweb.cgi?p=pcp/pcp.git;a=commit;h=b441980d53be1835b25f0cd6bcc0062da82032dd

CONFIRM - http://oss.sgi.com/cgi-bin/gitweb.cgi?p=pcp/pcp.git;a=blob;f=CHANGELOG;h=16c9cbb2f61d909487ea1c3171f4ab33e5648ac5;hb=fe51067ae869a4d59f350ac319b09edcb77ac8e6

FEDORA - FEDORA-2012-12076

FEDORA - FEDORA-2012-12024

SUSE - openSUSE-SU-2012:1081

SUSE - openSUSE-SU-2012:1079

SUSE - openSUSE-SU-2012:1036

DEBIAN - DSA-2533

SUSE - SUSE-SU-2013:0190

Related Patches

Novell SUSE 2013:7221 libpcp3 security update for SLE 11 SP2 i586

Novell SUSE 2013:7221 libpcp3 security update for SLE 11 SP2 x86_64

Novell SUSE 2013:8421 libpcp3 security update for SLE 10 SP4 i586

Novell SUSE 2013:8421 libpcp3 security update for SLE 10 SP4 x86_64


Last Updated: 27 May 2016 11:00:19