Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-3504

Overview

Vulnerability Score 3.6 3.6
CVE Id CVE-2012-3504
Last Modified 11 Oct 2012 12:00:00
Published 10 Oct 2012 02:55:02
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector LOCAL
Access Complexity LOW
Authentication NONE

CVE-2012-3504

Summary

The nssconfigFound function in genkey.pl in crypto-utils 2.4.1-34 allows local users to overwrite arbitrary files via a symlink attack on the "list" file in the current working directory.

Vulnerable Systems

Application

  • Fedoraproject Crypto-utils 2.4.1-34


References

MISC - https://bugzilla.redhat.com/show_bug.cgi?id=849256

XF - cryptoutils-genkey-symlink(79016)

BID - 55756

MLIST - [oss-security] 20121002 CVE-2012-3504: insecure temporary file usage in genkey perl script


Last Updated: 27 May 2016 11:00:56