Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-4001

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2012-4001
Last Modified 17 Sep 2012 12:00:00
Published 15 Sep 2012 06:37:17
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2012-4001

Summary

The mod_pagespeed module before 0.10.22.6 for the Apache HTTP Server does not properly verify its host name, which allows remote attackers to trigger HTTP requests to arbitrary hosts via unspecified vectors, as demonstrated by requests to intranet servers.

Vulnerable Systems

Application

  • Modpagespeed Mod Pagespeed 0.10.19.1

  • Modpagespeed Mod Pagespeed 0.10.22.4


References

CONFIRM - https://developers.google.com/speed/docs/mod_pagespeed/CVE-2012-4001

CONFIRM - https://developers.google.com/speed/docs/mod_pagespeed/announce-0.10.22.6


Last Updated: 27 May 2016 11:00:42