Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-4236

Overview

Vulnerability Score 4.3 4.3
CVE Id CVE-2012-4236
Last Modified 21 Aug 2012 12:00:00
Published 20 Aug 2012 03:55:05
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2012-4236

Summary

Cross-site scripting (XSS) vulnerability in the refresh_page function in application/modules/_main/views/_top.php in Total Shop UK eCommerce Open Source before 2.1.2_p1 allows remote attackers to inject arbitrary web script or HTML via the PATH_INFO.

Vulnerable Systems

Application

  • Totalshopuk Ecommerce 1.0

  • Totalshopuk Ecommerce 1.1

  • Totalshopuk Ecommerce 1.2

  • Totalshopuk Ecommerce 1.3

  • Totalshopuk Ecommerce 1.3.1

  • Totalshopuk Ecommerce 1.3.2

  • Totalshopuk Ecommerce 1.3.3

  • Totalshopuk Ecommerce 1.4.0

  • Totalshopuk Ecommerce 1.4.1

  • Totalshopuk Ecommerce 1.5.0

  • Totalshopuk Ecommerce 1.5.0.1

  • Totalshopuk Ecommerce 1.5.1

  • Totalshopuk Ecommerce 1.5.2

  • Totalshopuk Ecommerce 1.5.3

  • Totalshopuk Ecommerce 1.5.4

  • Totalshopuk Ecommerce 1.6.0

  • Totalshopuk Ecommerce 1.6.1

  • Totalshopuk Ecommerce 1.6.2

  • Totalshopuk Ecommerce 1.6.3

  • Totalshopuk Ecommerce 1.7

  • Totalshopuk Ecommerce 1.7.0

  • Totalshopuk Ecommerce 1.7.1

  • Totalshopuk Ecommerce 1.7.2

  • Totalshopuk Ecommerce 2.0.0

  • Totalshopuk Ecommerce 2.0.1

  • Totalshopuk Ecommerce 2.0.2

  • Totalshopuk Ecommerce 2.0.3

  • Totalshopuk Ecommerce 2.1.0

  • Totalshopuk Ecommerce 2.1.1

  • Totalshopuk Ecommerce 2.1.2


References

BID - 54985

MISC - http://www.reactionpenetrationtesting.co.uk/totalshop-uk-generic-xss.html

MLIST - [oss-security] 20120813 Total Shop UK eCommerce Generic Cross-Site Scripting

SECUNIA - 50238


Last Updated: 27 May 2016 10:57:36