Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-4271

Overview

Vulnerability Score 4.3 4.3
CVE Id CVE-2012-4271
Last Modified 14 Aug 2012 12:00:00
Published 13 Aug 2012 06:55:01
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2012-4271

Summary

Multiple cross-site scripting (XSS) vulnerabilities in bad-behavior-wordpress-admin.php in the Bad Behavior plugin before 2.0.47 and 2.2.x before 2.2.5 for WordPress allow remote attackers to inject arbitrary web script or HTML via the (1) PATH_INFO, (2) httpbl_key, (3) httpbl_maxage, (4) httpbl_threat, (5) reverse_proxy_addresses, or (6) reverse_proxy_header parameter.

Vulnerable Systems

Application

  • Mark Jaquith Bad Behavior 2.0.46

  • Mark Jaquith Bad Behavior 2.2.0

  • Mark Jaquith Bad Behavior 2.2.1

  • Mark Jaquith Bad Behavior 2.2.2

  • Mark Jaquith Bad Behavior 2.2.3

  • Mark Jaquith Bad Behavior 2.2.4

  • Wordpress -


References

XF - badbehavior-optionsgeneral-xss(75521)

BID - 53477

CONFIRM - http://plugins.trac.wordpress.org/changeset?old_path=%2Fbad-behavior&old=543807&new_path=%2Fbad-behavior&new=543807

MISC - http://packetstormsecurity.org/files/112619/WordPress-Bad-Behavior-Cross-Site-Scripting.html


Last Updated: 27 May 2016 10:51:40