Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-4286

Overview

Vulnerability Score 4.3 4.3
CVE Id CVE-2012-4286
Last Modified 23 Sep 2014 01:27:13
Published 16 Aug 2012 06:38:08
Confidentiality Impact NONE NONE
Integrity Impact NONE NONE
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2012-4286

Summary

The pcapng_read_packet_block function in wiretap/pcapng.c in the pcap-ng file parser in Wireshark 1.8.x before 1.8.2 allows user-assisted remote attackers to cause a denial of service (divide-by-zero error and application crash) via a crafted pcap-ng file.

Vulnerable Systems

Application

  • Wireshark 1.8.0

  • Wireshark 1.8.1


References

CONFIRM - http://anonsvn.wireshark.org/viewvc?revision=44074&view=revision

CONFIRM - http://anonsvn.wireshark.org/viewvc/trunk/wiretap/pcapng.c?r1=44074&r2=44073&pathrev=44074

CONFIRM - https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=7533

CONFIRM - http://www.wireshark.org/security/wnpa-sec-2012-24.html

SUSE - openSUSE-SU-2012:1067

BID - 55035

CONFIRM - https://blogs.oracle.com/sunsecurity/entry/multiple_vulnerabilities_in_wireshark3

SECUNIA - 51363

GENTOO - GLSA-201308-05

SECUNIA - 54425

SECUNIA - 50276


Last Updated: 27 May 2016 10:53:36