Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-4294

Overview

Vulnerability Score 5.8 5.8
CVE Id CVE-2012-4294
Last Modified 23 Sep 2014 01:27:14
Published 16 Aug 2012 06:38:08
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector ADJACENT_NETWORK
Access Complexity LOW
Authentication NONE

CVE-2012-4294

Summary

Buffer overflow in the channelised_fill_sdh_g707_format function in epan/dissectors/packet-erf.c in the ERF dissector in Wireshark 1.8.x before 1.8.2 allows remote attackers to execute arbitrary code via a large speed (aka rate) value.

Vulnerable Systems

Application

  • Wireshark 1.8.0

  • Wireshark 1.8.1


References

CONFIRM - http://anonsvn.wireshark.org/viewvc/trunk/epan/dissectors/packet-erf.c?r1=44377&r2=44376&pathrev=44377

CONFIRM - https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=7563

CONFIRM - http://www.wireshark.org/security/wnpa-sec-2012-16.html

CONFIRM - http://anonsvn.wireshark.org/viewvc?view=revision&revision=44377

SUSE - openSUSE-SU-2012:1067

BID - 55035

CONFIRM - https://blogs.oracle.com/sunsecurity/entry/multiple_vulnerabilities_in_wireshark3

SECUNIA - 51363

GENTOO - GLSA-201308-05

SECUNIA - 54425

SECUNIA - 50276


Last Updated: 27 May 2016 10:51:42