Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-4469

Overview

Vulnerability Score 2.6 2.6
CVE Id CVE-2012-4469
Last Modified 03 Dec 2012 12:00:00
Published 30 Nov 2012 05:55:00
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity HIGH
Authentication NONE

CVE-2012-4469

Summary

Cross-site scripting (XSS) vulnerability in the Hashcash module 6.x-2.x before 6.x-2.6 and 7.x-2.x before 7.x-2.2 for Drupal, when "Log failed hashcash" is enabled, allows remote attackers to inject arbitrary web script or HTML via an invalid token, which is not properly handled when administrators use the Database logging module.

Vulnerable Systems

Application

  • Simon Rycroft Hashcash 6.x-2.0

  • Simon Rycroft Hashcash 6.x-2.1

  • Simon Rycroft Hashcash 6.x-2.2

  • Simon Rycroft Hashcash 6.x-2.3

  • Simon Rycroft Hashcash 6.x-2.4

  • Simon Rycroft Hashcash 6.x-2.5

  • Simon Rycroft Hashcash 7.x-2.0

  • Simon Rycroft Hashcash 7.x-2.1


References

MLIST - [oss-security] 20121003 Re: CVE Request for Drupal Contributed Modules

MISC - http://drupal.org/node/1663306

CONFIRM - http://drupal.org/node/1650790

CONFIRM - http://drupal.org/node/1650784


Last Updated: 27 May 2016 10:49:52