Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-4487

Overview

Vulnerability Score 4.0 4.0
CVE Id CVE-2012-4487
Last Modified 05 Nov 2012 09:38:15
Published 02 Nov 2012 11:55:01
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity LOW
Authentication SINGLE_INSTANCE

CVE-2012-4487

Summary

The Subuser module before 6.x-1.8 for Drupal does not properly check "switch subuser" permissions, which allows remote authenticated parent users to change their role by switching to a subuser they created.

Vulnerable Systems

Application

  • Boombatower Subuser 6.x-1.0

  • Boombatower Subuser 6.x-1.1

  • Boombatower Subuser 6.x-1.2

  • Boombatower Subuser 6.x-1.3

  • Boombatower Subuser 6.x-1.4

  • Boombatower Subuser 6.x-1.5

  • Boombatower Subuser 6.x-1.6

  • Boombatower Subuser 6.x-1.7

  • Boombatower Subuser 6.x-1.x


References

MLIST - [oss-security] 20121007 Re: CVE Request for Drupal Contributed Modules

MLIST - [oss-security] 20121004 CVE Request for Drupal Contributed Modules

MISC - http://drupal.org/node/1700584

MISC - http://drupal.org/node/1700550


Last Updated: 27 May 2016 10:49:50