Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-4557

Overview

Vulnerability Score 5.0 5.0
CVE Id CVE-2012-4557
Last Modified 05 Dec 2013 12:18:06
Published 30 Nov 2012 02:55:01
Confidentiality Impact NONE NONE
Integrity Impact NONE NONE
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication NONE

CVE-2012-4557

Summary

The mod_proxy_ajp module in the Apache HTTP Server 2.2.12 through 2.2.21 places a worker node into an error state upon detection of a long request-processing time, which allows remote attackers to cause a denial of service (worker consumption) via an expensive request.

Vulnerable Systems

Application

  • Apache Http Server 2.2.12

  • Apache Http Server 2.2.13

  • Apache Http Server 2.2.14

  • Apache Http Server 2.2.15

  • Apache Http Server 2.2.16

  • Apache Http Server 2.2.17

  • Apache Http Server 2.2.18

  • Apache Http Server 2.2.19

  • Apache Http Server 2.2.20

  • Apache Http Server 2.2.21


References

CONFIRM - https://bugzilla.redhat.com/show_bug.cgi?id=871685

CONFIRM - http://svn.apache.org/viewvc?view=revision&revision=1227298

CONFIRM - http://httpd.apache.org/security/vulnerabilities_22.html#2.2.22

DEBIAN - DSA-2579

SUSE - openSUSE-SU-2013:0248

SUSE - openSUSE-SU-2013:0243


Last Updated: 27 May 2016 11:01:29