Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-4559

Overview

Vulnerability Score 6.8 6.8
CVE Id CVE-2012-4559
Last Modified 26 Aug 2013 11:27:32
Published 30 Nov 2012 05:55:01
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity MEDIUM
Authentication NONE

CVE-2012-4559

Summary

Multiple double free vulnerabilities in the (1) agent_sign_data function in agent.c, (2) channel_request function in channels.c, (3) ssh_userauth_pubkey function in auth.c, (4) sftp_parse_attr_3 function in sftp.c, and (5) try_publickey_from_file function in keyfiles.c in libssh before 0.5.3 allow remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via unspecified vectors.

Vulnerable Systems

Application

  • Libssh 0.4.7

  • Libssh 0.4.8

  • Libssh 0.5.0

  • Libssh 0.5.1

  • Libssh 0.5.2


References

MISC - https://bugzilla.redhat.com/show_bug.cgi?id=871612

BID - 56604

MLIST - [oss-security] 20121120 libssh 0.5.3 release fixes multiple security issues

CONFIRM - http://www.libssh.org/2012/11/20/libssh-0-5-3-security-release/

UBUNTU - USN-1640-1

DEBIAN - DSA-2577

SUSE - openSUSE-SU-2012:1622

SUSE - openSUSE-SU-2012:1620

SUSE - openSUSE-SU-2013:0130

XF - libssh-code-execution(80218)

MANDRIVA - MDVSA-2012:175

FEDORA - FEDORA-2012-18677

FEDORA - FEDORA-2012-18610


Last Updated: 27 May 2016 10:49:52