Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-4571

Overview

Vulnerability Score 2.1 2.1
CVE Id CVE-2012-4571
Last Modified 03 Dec 2012 12:00:00
Published 30 Nov 2012 05:55:01
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact NONE NONE
Availability Impact NONE NONE
Access Vector LOCAL
Access Complexity LOW
Authentication NONE

CVE-2012-4571

Summary

Python Keyring 0.9.1 does not securely initialize the cipher when encrypting passwords for CryptedFileKeyring files, which makes it easier for local users to obtain passwords via a brute-force attack.

Vulnerable Systems

Application

  • Python Keyring 0.9.1


References

MISC - https://bugs.launchpad.net/ubuntu/+source/python-keyring/+bug/1004845

UBUNTU - USN-1634-1

MLIST - [oss-security] 20121031 Re: CVE Request: Python keyring

CONFIRM - http://pypi.python.org/pypi/keyring


Last Updated: 27 May 2016 10:49:52