Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-5538

Overview

Vulnerability Score 2.1 2.1
CVE Id CVE-2012-5538
Last Modified 04 Dec 2012 12:00:00
Published 03 Dec 2012 04:55:02
Confidentiality Impact NONE NONE
Integrity Impact PARTIAL PARTIAL
Availability Impact NONE NONE
Access Vector NETWORK
Access Complexity HIGH
Authentication SINGLE_INSTANCE

CVE-2012-5538

Summary

Cross-site scripting (XSS) vulnerability in the FileField Sources module 6.x-1.x before 6.x-1.6 and 7.x-1.x before 7.x-1.6 for Drupal, when the field has "Reference existing" source enabled, allows remote authenticated users to inject arbitrary web script or HTML via the filename of an uploaded file.

Vulnerable Systems

Application

  • Nathan Haug Filefield Sources 6.x-1.0

  • Nathan Haug Filefield Sources 6.x-1.1

  • Nathan Haug Filefield Sources 6.x-1.2

  • Nathan Haug Filefield Sources 6.x-1.3

  • Nathan Haug Filefield Sources 6.x-1.4

  • Nathan Haug Filefield Sources 6.x-1.5

  • Nathan Haug Filefield Sources 6.x-1.x

  • Nathan Haug Filefield Sources 7.x-1.2

  • Nathan Haug Filefield Sources 7.x-1.3

  • Nathan Haug Filefield Sources 7.x-1.4

  • Nathan Haug Filefield Sources 7.x-1.5

  • Nathan Haug Filefield Sources 7.x-1.x


References

MLIST - [oss-security] 20121120 Re: CVE Request for Drupal Contributed Modules

MISC - http://drupal.org/node/1789306

CONFIRM - http://drupal.org/node/1789302

CONFIRM - http://drupal.org/node/1789300


Last Updated: 27 May 2016 11:01:26