Lumension® Endpoint Intelligence Center

Intelligence Center » Browse All Vulnerabilities » CVE-2012-5610

Overview

Vulnerability Score 6.5 6.5
CVE Id CVE-2012-5610
Last Modified 18 Dec 2012 12:00:00
Published 17 Dec 2012 08:55:07
Confidentiality Impact PARTIAL PARTIAL
Integrity Impact PARTIAL PARTIAL
Availability Impact PARTIAL PARTIAL
Access Vector NETWORK
Access Complexity LOW
Authentication SINGLE_INSTANCE

CVE-2012-5610

Summary

Incomplete blacklist vulnerability in lib/filesystem.php in ownCloud before 4.0.9 and 4.5.x before 4.5.2 allows remote authenticated users to execute arbitrary PHP code by uploading a file with a special crafted name.

Vulnerable Systems

Application

  • Owncloud 3.0.0

  • Owncloud 3.0.1

  • Owncloud 3.0.2

  • Owncloud 3.0.3

  • Owncloud 4.0.0

  • Owncloud 4.0.1

  • Owncloud 4.0.2

  • Owncloud 4.0.3

  • Owncloud 4.0.4

  • Owncloud 4.0.5

  • Owncloud 4.0.6

  • Owncloud 4.0.7

  • Owncloud 4.0.8


References

CONFIRM - https://github.com/owncloud/core/commit/f599267

CONFIRM - https://github.com/owncloud/core/commit/6540c0fc63

CONFIRM - https://github.com/owncloud/core/commit/4b86c43

CONFIRM - https://github.com/owncloud/core/commit/3cd416b667

MLIST - [oss-security] 20121130 Re: CVE Request: owncloud

SECUNIA - 51357

CONFIRM - http://owncloud.org/security/advisories/oc-sa-2012-005/

CONFIRM - http://owncloud.org/changelog/


Last Updated: 27 May 2016 11:01:28